We have moved to Git. This repository is only provided for compatibility with old installations. Learn how to migrate your installation here.

changeset 201:cbb5cf71be86

adding net-misc/asterisk-softmodem
author Daniel Neugebauer <dneuge@energiequant.de>
date Thu, 27 Apr 2017 23:17:47 +0200
parents 69881ed76bc6
children f5f54e0e27a3
files net-misc/asterisk-softmodem/Manifest net-misc/asterisk-softmodem/asterisk-softmodem-20160525.ebuild
diffstat 2 files changed, 35 insertions(+), 0 deletions(-) [+]
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/asterisk-softmodem/Manifest	Thu Apr 27 23:17:47 2017 +0200
@@ -0,0 +1,1 @@
+EBUILD asterisk-softmodem-20160525.ebuild 820 SHA256 0c0ae58d7896df9e5e515a01c98c84b132a5150009c3cd2f8496b2ecdf317d88 SHA512 8de3d73c665f750f5ec7fd754c9c97a22f97861b74e4f82830fd20cc5a4d382a5516b7a1957f15a5f60cf884f9f0230f6061eb306487927f882503d1035a6763 WHIRLPOOL 668acefaeb2a97ddbc0d9281d459d5ea30c7274585fabb0070bf15041adf33ad6b0137a9edfee5927ecc4de22a7e0641df7dd07b81784e37452df89d8a0b947b
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/net-misc/asterisk-softmodem/asterisk-softmodem-20160525.ebuild	Thu Apr 27 23:17:47 2017 +0200
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# based on net-misc/asterisk-app_rxfax ebuild provided by mva and luke-jr overlays
+
+EAPI=6
+
+inherit git-r3
+
+DESCRIPTION="Asterisk application providing a V.21/V.22/V.23 compatible soft-modem for inbound connections"
+HOMEPAGE="https://github.com/proquar/asterisk-Softmodem"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+DEPEND="media-libs/spandsp
+        >=net-misc/asterisk-13"
+
+EGIT_REPO_URI="https://github.com/proquar/asterisk-Softmodem.git"
+EGIT_COMMIT="14e5b4f9ebbd8dcbf107a397e26b5385771bdff7"
+
+MyPN="app_softmodem"
+
+src_compile() {
+	gcc $CFLAGS -shared -fPIC -lspandsp -o "${MyPN}".{so,c} || die compile
+}
+
+src_install() {
+	exeinto "/usr/lib/asterisk/modules"
+	doexe "${MyPN}.so" || die install
+}